[kaffe] support for JDk 1.2 and higher?

mariner ux marinerux at gmx.net
Thu Feb 17 05:05:46 PST 2005

> mariner ux wrote:
> > Hi there, 
> Hi Corsin,
> > I need a JVM on HP-UX 10.20 which support's JDK 1.2 and higher. I
> thought I
> > could try it with kaffe, so I installed it.
> Cool. Thanks for trying it out. I'd recommend going with the CVS head 
> at, as it is much more complete then 1.1.4. If you are using CVS head, 
> hop on #kaffe for hands on help, if necessary.
> > Kaffe installed sucessfully. I tried to compile the source code of my
> > application I worte.
> > But there I have still Problems...
> > Does the current version, which I installed, support JDk 1.2 and higher?
> Most of it, yes. ~ three quarters of the APIs of 1.4 are implemented, 
> i.e. the most commonly used stuff is covered.
> > If Yes what could be the Problems for this Errors:
> > 
> > :javac HPUXldap.java
> > HPUXldap.java:19: Class com.novell.ldap.LDAPAttribute not found in
> import.
> > import com.novell.ldap.LDAPAttribute;
> >        ^
> > HPUXldap.java:20: Class com.novell.ldap.LDAPAttributeSet not found in
> > import.
> > import com.novell.ldap.LDAPAttributeSet;
> >        ^
> > HPUXldap.java:21: Class com.novell.ldap.LDAPConnection not found in
> import.
> > import com.novell.ldap.LDAPConnection;
> >        ^
> > HPUXldap.java:22: Class com.novell.ldap.LDAPEntry not found in import.
> > import com.novell.ldap.LDAPEntry;
> >        ^
> > HPUXldap.java:23: Class com.novell.ldap.LDAPException not found in
> import.
> > import com.novell.ldap.LDAPException;
> >        ^
> > HPUXldap.java:24: Class com.novell.ldap.LDAPSearchResults not found in
> > import.
> > import com.novell.ldap.LDAPSearchResults;
> >        ^
> > HPUXldap.java:25: Class com.novell.ldap.util.Base64 not found in import.
> > import com.novell.ldap.util.Base64;
> >
> You need to put jldap.jar on your CLASSPATH.
> > HPUXldap.java:28: Class java.util.Iterator not found in import.
> > import java.util.Iterator;
> >        ^
> That one is pretty odd. Could you try with CVS head? It implements that 
> class afaict.
> Speaking of Novell's JLDAP [1], I've checked it out, trying to see if it 
> would build and run with Kaffe from CVS head. Lo and behold, after I put 
> httpclient 2.0 jar in my CLASSPATH it built. And passed many of the 
> regression tests, though there were some failures, afaict. So it should 
> work in general, and help from someone who understands LDAP, i.e you, to 
> iron the remaining bugs out exposed by Novell's test suite would be cool
> :)
> cheers,
> dalibor topic
> [1] http://www.openldap.org/jldap/


I tried to get the CVS head, but unfortunately i couldn't get it from there
cause the connection to the server failed.

-bash-2.05b# export CVSROOT=:pserver:readonly at cvs.kaffe.org:/cvs/kaffe
-bash-2.05b# echo $CVSROOT
:pserver:readonly at cvs.kaffe.org:/cvs/kaffe
-bash-2.05b# cvs login
Logging in to :pserver:readonly at cvs.kaffe.org:2401/cvs/kaffe
CVS password:
cvs [login aborted]: connect to cvs.kaffe.org( failed:
Connection timed out

Is there an other way to get kaffe in the currentest stadium?
I would like to test it and run my application on it...

IRC also didn't  work, because im sitting here behind the firewall of the
company im working for.

After this, I thougt i could try to compile my program again. 
And see there : It works... 
I could could compile it with javac of kaffe and ther were no error. I don't
know why, I think I haven't changed any settings. The Classpath was set as
same as the first time i tried.

>:javac *.java

After this sucessfull compilation I used java to run the appplication. But
now I have this error:

(kaffe had the same error)

>:java HPUXldap
   at java.lang.Thread.run (Thread.java:307)

Is it a problem of the stack size? How can I fix this Problem?


DSL Komplett von GMX +++ Supergünstig und stressfrei einsteigen!
AKTION "Kein Einrichtungspreis" nutzen: http://www.gmx.net/de/go/dsl

More information about the kaffe mailing list