[kaffe] Re: japitools 0.9.5 NullPointerException

Michael Koch konqueror at gmx.de
Thu Jan 27 22:52:33 PST 2005

Am Freitag, 28. Januar 2005 01:36 schrieb Peter Connolly:
> When I run japitools' japize against two versions of the Sybase
> JConnect2 library: jconn2.jar, I get a large number of
> NullPointerExceptions.
> I am running 0.9.5 of japitools.  I have run J2SE JDK 1.4.1 and
> 1.5.0 with japitools and I get the same results...i.e., many
> NullPointerExceptions.  I'm including japitools.jar and the 1.4.1
> rt.jar in the CLASSPATH.

Why do you put rt.jar into CLASSPATH ? Have you tried it with any free 
VM ? I saw a similar case when I compile the java sources with the 
wrong compiler. E.g. On my setup I may not use jikes to compile the 
classes. Might be  a japitools bug.

Sorry, but we dont support proprietary VMs here. This project is 
targeted to provide a class library implementation for free Java VMs.
We are only working with free VMs because we can debug them and fix 
them as we need.

Homepage: http://www.worldforge.org/

More information about the kaffe mailing list