[kaffe] Getting 1.1.5 running on OpenBSD 3.7
truk at optonline.net
Tue Jul 19 06:29:48 PDT 2005
From: "Vacuum Joe" <vacuumjoe at yahoo.com>
> Thanks for the tip, Dalibor. Here's the news:
> First, various dependencies need to be installed,
> mainly gtk2+ and zip. I got those using the plain old
> OpenBSD package system.
> Second, the configure script has a hard time finding
> some libraries. I couldn't get it to find gmp, and it
> also could never find esd.h, even though those were
> right there in /usr/local. I even tried
> --with-esd=/usr/local and that didn't help. It would
> get through configure but when it was compiling the
> sound, it bonked out. I'm sure this is a simple
> problem. If anyone makes a patch for this, let me
> know and I'll try it.
> Third, for whatever reason, jikes bonked with an
> out-of-memory error when compiling rt.jar. I cranked
> it up to 7gb of swap, which should be enough. I am
> running this on a clunky old Pentium II so maybe that
> architecture is not letting it use all that swap. Not
> sure. Maybe OpenBSD itself is having some bad
> interaction with jikes. gcc 4.0.1 also could not
> compile, also because of an out-of-memory error, so
> this may not be a Kaffe problem. So following
> Dalibor's suggestion, I picked up a ready-made rt.jar
> and told configure to use it.
OpenBSD's process limits default to low values. You
need to increase them using ulimit or limit depending
on your shell.
> Fourth, the whole thing can only be built with Gnu
> make, which I built from source.
> So, finally, this is what I did for configure:
> configure --enable-pure-java-math
> (this was after saving the rt.jar file into the kaffe
> And it works! I got a simple hello world class to run
> I'm working on getting Tomcat running. Tomcat 5.5
> wants a Java 1.5 version. Tomcat 5.0 needs to have a
> JDK, not a JRE (presumably for compiling JSPs). If
> anyone has some quick tips on these I'll try them out.
> I'm also going to try some simple Swing apps.
Tomcat 5.0 is in ports. Tomcat 5.5 isn't yet for no other
reason then me slacking. Tomcat 5.5 doesn't strickly
require 1.5. It can be run using 1.4 if you use the
compatiblilty libs provided.
More information about the kaffe