[kaffe] ./configure error in the kaffe-1.1.5
robilad at kaffe.org
Mon May 16 05:02:41 PDT 2005
toodulli at netian.com wrote:
> Hi all..
> When I have ./configure, I found the error message.
> checking for gtk+-2.0 >= 2.4 gthread-2.0 >= 2.2 libart-2.0 gdk-pixbuf-2.0...
> Requested 'gtk+-2.o >=' but version of GTK+ is 2.2.1
> configure: error: Library requirements (gtk+-2.0 >=2.4 gthread-2.0 >= 2.2
> libart-2.- gdk-pixbuf-2.0)not met: consider adjusting the PKG_CONFIG_PATH
> environment variable if your libraries are in a nonstandard prefix so pkg-config
> can find them
> If I upgrade gtk+ version, It is possible to compile kaffe-1.1.5.
> I want to know what's the problems.
Kaffe now uses GNU Classpath for almost all of its class libraries,
including AWT and Swing. GNU Classpath's AWT implementation uses some
features from gtk 2.4 that were not available in versions prior to that,
afaik. If you do not need AWT support you can pass the
--disable-native-awt flag to configure. See FAQ/FAQ.awt for more details.
More information about the kaffe