[kaffe] Re: Kaffe on MIPS64/Linux

Mike Kozlowski mike.kozlowski at pts.nl
Tue Aug 15 05:43:53 PDT 2006

> Hi all
> I was wondering if anyone has ever tried running Kaffe on a MIPS64/Linux
> system. I tried compiling it (with jikes java compiler) and it told me
> only o32 ABI is supported. When I recompiled everything (including jikes)
> and tried to invoke the VM with a simple “hello, world”
.class files, it
> aborts with a message saying “illegal instruction”.
> Any help is greatly, deeply appreciated.
> Thanks
> Durga

Hi Durga,

Couple of days ago I have encountered the same problem while
cross-compiling Kaffe for Mipsel. Short inspection with ldd (version for
mipsel binaries) of the library "libkaffevm-1.1.7.so" revealed that apart
from including some native libraries, it also included library
"/lib/ld.so.1". It was quite strange to me, as I have passed propper paths
to libraries for the ./configure script. As I couldn't find any neat and
reasonable solution, I simply copied the mipsel version of ld.so.1 to
/lib/ (of course making the backup). After the compilation the problem was
solved - I can receive nice "Hello World!" on my mipsel machine. I hope it
helps you.

As long as we are with the topic of Kaffe for Mips/Linux, could you tell
me, what size is your port of Kaffe? I need to make mine as small as
possible, of course keeping reasonable fuctionality. Any hints?



More information about the kaffe mailing list