[kaffe] Illegal Instruction with ARM and JIT

Andreas Kielkopf a.kielkopf at gleisplanspiel.de
Sat Jul 29 09:34:07 PDT 2006


We also tried to compile Kaffe for the ARM720T and have the same
The Interpreter works, but if we try to use the JIT, kaffe stops with an
"Illegal Instruction". We tried to debug, but we couldn't get the
debugger to work on our Target.

We also noticed a diffrence between our Target (Illegal Instruction) and
the same binary running in the "Scratchbox". In Scratchbox the same
binary worked without an "Illegal Instruction".

It would be very fine for us, to be able to use the JIT on our target.
So we hope anyone knows the solution.

 On Fri, 2006-07-28 at 12:01 -0700, kaffe-request at kaffe.org wrote:
> Send kaffe mailing list submissions to
> 	kaffe at kaffe.org
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://kaffe.org/cgi-bin/mailman/listinfo/kaffe
> or, via email, send a message with subject or body 'help' to
> 	kaffe-request at kaffe.org
> You can reach the person managing the list at
> 	kaffe-owner at kaffe.org
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of kaffe digest..."
> Today's Topics:
>    1. Segmentation fault using JIT on ARM (Pablo Roman)
> ----------------------------------------------------------------------
> Message: 1
> Date: Fri, 28 Jul 2006 12:30:00 +0200
> From: Pablo Roman <pablo at microelec.uab.es>
> Subject: [kaffe] Segmentation fault using JIT on ARM
> To: Kaffe mailing list <kaffe at kaffe.org>
> Message-ID:
> 	<80344857582B9C4ABFCAB5EFCC98EAFE097D85 at umem.microelec.uab.es>
> Content-Type: text/plain; charset=utf-8
> Hello,
> Here, at my University department, we are trying to run Kaffe on a single board computer with an arm9.
> We've managed to run it with the interpreter engine but when we try to run it with the JIT one we get a segmentation fault. I think JIT is supported on ARM as I've seen some people using it successfully.
> We've tried Kaffe 1.1.6, 1.1.7 and CVS version with GCC 3.4.4 and 4.0.1 using this configure parameters (this is using the SBC provider compiler but I also tried GCC 4.0.1 built with crosstool and got the same result):
> ../kaffe-1.1.7/configure --prefix=/usr/local --host=arm-linux --with-kaffe-nanox-awt --with-nanox-include=/opt/emlix/netdcu8/microwindows/src/include --with-nanox-library=/opt/emlix/netdcu8/microwindows/src/lib --with-include=/opt/emlix/netdcu8/src/linux26/linux26/include --with-libraries=/opt/emlix/netdcu8/src/linux26/linux26/lib/ CC=arm-linux-gcc CXX=arm-linux-g++ CPP=arm-linux-cpp LD=arm-linux-ld KAFFEH=/home/kaffe/bin/kaffeh --with-engine=intrp --without-classpath-gtk-awt --disable-vmdebug --disable-debug --without-kaffe-x-awt --without-kaffe-gtk-awt --without-x --disable-gtk-peer
> I've searched a lot and tried all what I know. I hope someone had the same problem and found a way to solve it.
> Lots of thanks, and sorry for my bad English
> ------------------------------
> _______________________________________________
> kaffe mailing list
> kaffe at kaffe.org
> http://kaffe.org/cgi-bin/mailman/listinfo/kaffe
> End of kaffe Digest, Vol 26, Issue 42
> *************************************
Andreas Kielkopf <a.kielkopf at gleisplanspiel.de>

More information about the kaffe mailing list