[kaffe] Segmentation fault using JIT on ARM

Pablo Roman pablo at microelec.uab.es
Fri Jul 28 03:30:00 PDT 2006

Here, at my University department, we are trying to run Kaffe on a single board computer with an arm9.
We've managed to run it with the interpreter engine but when we try to run it with the JIT one we get a segmentation fault. I think JIT is supported on ARM as I've seen some people using it successfully.
We've tried Kaffe 1.1.6, 1.1.7 and CVS version with GCC 3.4.4 and 4.0.1 using this configure parameters (this is using the SBC provider compiler but I also tried GCC 4.0.1 built with crosstool and got the same result):
../kaffe-1.1.7/configure --prefix=/usr/local --host=arm-linux --with-kaffe-nanox-awt --with-nanox-include=/opt/emlix/netdcu8/microwindows/src/include --with-nanox-library=/opt/emlix/netdcu8/microwindows/src/lib --with-include=/opt/emlix/netdcu8/src/linux26/linux26/include --with-libraries=/opt/emlix/netdcu8/src/linux26/linux26/lib/ CC=arm-linux-gcc CXX=arm-linux-g++ CPP=arm-linux-cpp LD=arm-linux-ld KAFFEH=/home/kaffe/bin/kaffeh --with-engine=intrp --without-classpath-gtk-awt --disable-vmdebug --disable-debug --without-kaffe-x-awt --without-kaffe-gtk-awt --without-x --disable-gtk-peer
I've searched a lot and tried all what I know. I hope someone had the same problem and found a way to solve it.
Lots of thanks, and sorry for my bad English

More information about the kaffe mailing list