[kaffe] Kaffe Segmentation Fault

Mike Drozdick mikey66 at comcast.net
Tue Jun 20 23:58:30 PDT 2006



I successfully built/installed/tested Kaffe on a i386 linux machine running
CentOS4.3, building with gcc 3.4.5. I tested kaffe with a simple "java
HelloWorld" and everything worked fine! (The "java" is the kaffe alias.)


I repeated the exact procedure on another machine running Fedora Core 5,
building with gcc 4.1.1. Everything built, but when I tried "java
HelloWorld" I got a Sementation Fault with no additional information. I
tried MANY experiments altering various <configure> options; no change.


Suspecting the compiler, I reverted to gcc 3.4.5 as in the successful case,
repeated the entire procedure from scratch on the Fedora 5 machine, and
still got the Segmentation Fault.


Does anyone recognize this symptom or have any ideas? Any thoughts would be
most welcome.





-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://kaffe.org/pipermail/kaffe/attachments/20060621/04300bac/attachment-0004.htm 

More information about the kaffe mailing list