[kaffe] Building Kaffe!

vlad vlad666 at web.de
Tue Oct 31 01:22:08 PST 2006

Hey Guilhem,

Yes, of course!

On closer look into the 
"libraries/javalib/external/classpath/lib/Makefile.*" dir I've found 
something like:
-extdirs '' -sourcepath '' --classpath $(compile_classpath) -d . @classes"
Further the 'compile-classes' target uses this $(JAVAC) to compile.
Since JIKES was not set to any value in my Makefile (because I did not 
have installed it), the $(JAVAC) value exactly matched the stupid 
command-line which led to my error while making kaffe.
Finally I also supposed, that installing jikes would remedy ;-) !

Now Kaffe compiles completely, and I can investigate the code.

Thank you for your help!!!

Best Regards,


Guilhem Lavaux wrote:
> Hi Vlad,
> You must not configure anything else but the top directory. The other 
> configure are started by that one. The problem you are getting is 
> because jikes has not been detected. Try installing jikes with 
> 'apt-get install jikes'
> Guilhem.
> vlad wrote:
>> Hi,
>> Because I am getting more and more obscured by even more details, I 
>> wanna tell you what I did to attain here:
>> - first I checked out the 'kaffe' module from 
>> "cvs.kaffe.org:/cvs/kaffe" (got it not from the ftp source)
>> - when running ./configure it fails with the message: "configure: 
>> error: GTK+ peers requested but no X library available" ... to fix 
>> this one I run configure with
>> "--without-x --without-classpath-gtk-awt --without-kaffe-qt-awt 
>> --without-kaffe-x-awt --disable-gtk-peer" ...
>> now configure succeeds! (is there any other fixup?)
>> - when running 'make', it enters into 
>> "libraries/javalib/external/classpath/lib" and fails on:
>> "Adding java source files from srcdir '..'.
>> Adding java source files from VM directory ../vm/reference
>> F  -bootclasspath '' -extdirs '' -sourcepath '' --classpath    
>> ../vm/reference:..:../external/w3c_dom:../external/sax:../external/relaxngDatatype:.:: 
>> -d . @classes
>> make[3]: F: command not found
>> make[3]: *** [compile-classes] error 127"
>> - In '/libraries/javalib/external/classpath/' I've found another 
>> configure, which I executed with the same parameters as described 
>> above! I run make again and it led to the previous error with the 
>> .stamp target
>> Now I have cleaned all Makefile.in files in the tree and updated then 
>> with "cvs -qz3 update" ...
>> Each make call leads now to the "make[3]: F: command not found" error 
>> as described above ...
>> Do you have an idea how I could manage it? What happens?
>> Thank you for any reply in advance!
>> Best Regards
>> Vladimir
>> Guilhem Lavaux wrote:
>>> Hi,
>>> The target to produce this .stamp file is present in
>>> libraries/javalib/vmspecific/Makefile.in (and Makefile too of course).
>>> It is generated by newer automake. Maybe automake has tried to rebuild
>>> your Makefiles ? I suggest you clean up Makefile.in in your tree and
>>> reupdate from cvs using 'cvs -qz3 update' and see if it improves the
>>> situation.
>>> Regards,
>>> Guilhem.
>> _______________________________________________
>> kaffe mailing list
>> kaffe at kaffe.org
>> http://kaffe.org/cgi-bin/mailman/listinfo/kaffe

More information about the kaffe mailing list