[kaffe] Seg Fault on Embedded System

Kevin DeVries kevin at verticalpower.com
Fri Sep 29 15:49:50 PDT 2006

Lowdown: creating cross-compiled kaffe for embedded xscale (arm)
processor; running java/kaffe on target generates Seg Fault on simple
(any) java program


Kaffe version: 1.1.7

Host machine: x86-linux (2.4.32)

Target machine: arm-linux (2.6.17)


General process:


host%untar'ed kaffe-1.1.7

host%mkdir native

host%mkdir arm

host%cd native; make config; make; make install


host%cd arm

host%CC=<xgcc> NM=<xnm> AR=<xar> ../kaffe-1.1.7/configure
-host=arm-linux -build=i686-linux -disable-native-awt
-disable-xawt-xi18n -without-kaffe-qt-awt -disable-gtk-peer
-prefix=/opt/kaffe/arm -disable-sound

<success; 11th time is the charm>

host% make; make install



host% <copy server:/opt/kaffe/arm to target:/opt/kaffe/arm>



public class Hello


  public static void main (String[] argv)


     int i=1;         // I've even tried without this line




host% javac Hello

host% <copy Hello.class to target>


target% java Hello

Segmentation Fault

target% java -v Hello


Loading java/util/Comparator.class(/opt/kaffe/arm/jre/lib/glibj.zip)

Segmentation Fault


host% java Hello

host% <no segv>


I've tried both a standard distribution of javac and the kaffe
distribution of javac and got the same results.

And I can (obviously) run a cross-compiled executable on my target.


Anything that I should take a look at? The only thing I can think of is
that it's not finding a library or that a library is out of sync. I
don't have a debugger on the target @ this time, so heading down that
path is do-able, just a lot of effort that I'm not ready for.


Thanks much,


Kevin DeVries

Vertical Power

317 Commercial St NW

Albuquerque, NM 87102

505 241 9333 (c)/(w)



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://kaffe.org/pipermail/kaffe/attachments/20060929/f337a2e3/attachment-0004.htm 

More information about the kaffe mailing list