[kaffe] Re: libz dependency

Dalibor Topic robilad at kaffe.org
Sun Jul 1 11:24:32 PDT 2007

Kiyo Inaba wrote:
> Kiyo Inaba wrote: 
>> Dalibor Topic wrote:
>>> Yes, now that we depend on it, we should make sure it's there in
>>> configure. Thanks, I'll check in a patch.
>> Oops, I misunderstand the name of the library. I have 'libz' installed.
>> One possibility is the (os) installed version is 1.1.4. Is this version
>> to old?
> Verified.

thanks for hunting that one down, Kiyo.

> When I have libz.so.1.1.4 and link this to libz.so, the regression fails.
> But when I have libz.so.1.2.3, the regression passes. This in only tested
> on i386/linux and later I will check several other environments.
> I am not sure which is the oldest version which is ok for kaffe.

The zlib site recommends against using versions older than 1.2.3 due to 
security issues. [1]

> Dalibor, could you please add some code to check the version of libz?

I could check if ZLIB_VERNUM >= 0x1230, and abort configure accordingly, 
to make sure kaffe is built with zlib 1.2.3 or higher.

dalibor topic

[1] http://www.zlib.net/

"Version 1.2.3 eliminates potential security vulnerabilities in zlib 
1.2.1 and 1.2.2, so all users of those versions should upgrade immediately."

More information about the kaffe mailing list