Problem under linux

hsdc1l at hsdc1l at
Sun Apr 20 06:40:03 PDT 1997


: hi
: I just downloaded kaffe-0.8.3 with all the archives needed, but it gives
: me a compilation error. I traced it to the file "external.c" in
: "kaffe/kaffevm". I also saw "slib.h" in the same directory and found out
: that that the macro LIBRARYHANDLE is being defined incorrectly. That's the
: reason that I get the error "undefined storage type" in line 67 of
: "external.c". I looked for the header file "dl.h" on my hard-disk but
: couldn't find it anywhere. The only unusual storage type I saw was "shl_t"
: in the "slib.h" file.

	The problem is that at least some versions of Linux (I am also
	running Slackware), although they support "dlfcn"-style dynamic
	libraries, they do not come with the dlfcn.h header file.  I
	created a stub version of the header file in /usr/include and
	reran configure and everything worked fine.  I went back later
	and created a "real" version of the header file based on the 
	dlopen man page, which results in a couple of compiler warnings,
	but nothing that prohibits compiling or running kaffe...
: I run Slackware Linux 3.1 (kernel-2.0.0). Can anyone give me a solution?
: I hope that you're reading this Tim (Wilkinson)!
: dev


More information about the kaffe mailing list