Compiling Kaffe 1.0b4 on Win96/CYGWIN/ make check fails

jim hopper hopperj at
Tue Aug 17 12:28:12 PDT 1999


thanks for thinking about me!  My problem turned out to be user 
stupidity.  i did nt know how it was supposed to work.  my failure is 
that i get no printout of any kind when running java classes. they 
don't barf, or otherwise indicate a problem, they just fail to print 
anything out.  i thought the out file was the output, but its 
actually the expected results, its the fail file which in my case is 
blank that has my output.

I havent gotten back to lok at why yet. someone suggested trying 
jikes as the java compiler.  i tried to build it but it wants wchar.h 
and won't even configure because i don't have it even though i set 
the system up to -DNO_WCHAR.  so i dropped that for now.  i am going 
to mod native_methods.c to have it do the printout of what it gets so 
i can debug the sysdepCallMethods without getting any java output.

best jim

At 2:16 PM -0500 8/17/99, Phil Kelly wrote:
>Could the line end problem also be what Jim Hopper was seeing the 
>other day on Powerpc?  I'm not sure what type of line-ends it 
>produces, but at one point he said:
>"jim hopper on Fri, 13 Aug 1999 was captured by our super secret 
>microphone saying":
> >Now i really have a mystery. when i do make check i get like
> >
> >PASS:
> >FAIL:
> >FAIL:
> >PASS:
> >FAIL:
> >FAIL:
> >
> >but if i look in at end where it gives expected
> >results and compare it with whats in HelloWorldApp.out expected
> >results match actual results, but for some reason it being shown as
> >failed. i looked at the first six or so and all seem to pass when
> >you look at the *.out files. to weird! Perhaps this port is in better
> >shape than i though. perhaps i need a newer make or something, i
> >will download make from gnu site and build it.>
>So, maybe the output of the script and the "sed'ing" need to both have
>their line-ends stripped before comparison?
>"Earlier today Alexandre Oliva wrote":
> >
> > On Jul 13, 1999, Pavel Roskin <pavel_roskin at> wrote:
> >
> > > I've attached a patch which fixes it.
> >
> > I couldn't find any patch, but I worked it out anyway.
> >
> > > Now HelloWorldApp can be compiled and run. However, its output contains
> > > dos-style line ends, while the expected output (produced by sed) is in
> > > unix style.
> > > Thus, "cmp" finds the difference and the test fails.
> >
> > Yup.  I found out filtering the program output through `grep .', that
> > removes `\r's.
> >
> > --
> > Alexandre Oliva IC-Unicamp, Bra[sz]il
> > oliva@{,guarana.{org,com}} aoliva@{,}
> > oliva@{,,{egcs,sourceware},}
> > ** I may forward mail about projects to mailing lists; please use them
>Phil Kelly
>Delphi Delco Electronic Systems
>Embedded Computing Technologies                    Phone (765) 451-0776
>Internet: pwkelly at               Kokomo, Indiana, USA

At a recent computer software engineering course in the US, the participants
were given an awkward question to answer.  "If you had just boarded an
airliner and discovered that your team of programmers had been responsible
for the flight control software, how many of you would disembark
                     unknown author

More information about the kaffe mailing list