[kaffe] Makefile output when i run it in Windows2000, just he lp me in thi s

Muthuswamy R muthuswamyr at aztec.soft.net
Thu Aug 15 23:16:30 PDT 2002

   The addition of config-hacks.h as defined in  
   is not working.
   the content of config-hacks.h looks like this, where it includes
	#if defined(__WIN32__)
	#if defined(HAVE_WINSOCK2_H)
	 #include <winsock2.h>
	#if _MSC_VER < 1200
	#define HAVE_INT32 1
   but the HAVE_WINSOCK2_H doesn't look like is defined in the config.
because of 
   which the file is not getting included.
   So the same error is coming...like this
gcc -g -O2 -Wall -Wstrict-prototypes -o kaffe-bin.exe main.o version.o
fe-bin.exeS.o -Wl,--export-dynamic
a -L/usr/local/lib ../../libraries/clib/net/.libs/libnet.a
io/.libs/libio.a ../../libraries/clib/zip/.libs/libzip.a -lz
b/math/.libs/libmath.a ../../libraries/clib/management/.libs/libmanagement.a
oft/clib/.libs/libmicrosoft.a ../kaffevm/.libs/libkaffevm.a -Wl,--rpath
../kaffevm/.libs/libkaffevm.a(syscalls.lo): In function
fined reference to `h_errno'
../kaffevm/.libs/libkaffevm.a(syscalls.lo): In function
fined reference to `h_errno'
collect2: ld returned 1 exit status
rm -f .libs/kaffe-bin.exeS.o
make[2]: *** [kaffe-bin.exe] Error 1
make[2]: Leaving directory `/cygdrive/d/kaffe-1.0.7/kaffe/kaffe'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/cygdrive/d/kaffe-1.0.7/kaffe'
make: *** [all-recursive] Error 1


reply me
-----Original Message-----
From: Dalibor Topic [mailto:robilad at yahoo.com]
Sent: Wednesday, August 14, 2002 7:40 PM
To: Muthuswamy R; 'kaffe at kaffe.org'
Subject: Re: [kaffe] Makefile output when i run it in Windows2000, just
help me in thi s

Hi Muthuswamy,
--- Muthuswamy R <muthuswamyr at aztec.soft.net> wrote:
thank you for your bug report. I assume that you are
compiling on cygwin. Could you try to fix it as
proposed in this mail:


and see if that works for you?

best regards,

dalibor topic

Do You Yahoo!?
HotJobs - Search Thousands of New Jobs

More information about the kaffe mailing list