[kaffe] ld : -ldl not found connot compile kaffe-bin

Saifuddin Rangwala saifuddingroups at yahoo.co.in
Sat Nov 8 00:10:03 PST 2003

I am trying to port kaffe-1.0.7 to linux-2.4.6 the
architecture being arm-cs89712.
I am using gcc-2.95.3 and uclibc-0.9.12 as the cross
development tools.
I have successfully compiled and installed kaffe as
dynamically linked vm.
But I think I need static vm,bin and lib on cs89712

When I tried only --with-staticvm, it worked,
but when I treid --with-static-bin --with-staticvm, it
gave following error while
installing : -
cannot find -ldl
Also I have specified which ld to use while
configuring, still it using ld generated by binutils
and not uclibc.
Scroll down to view the trace of the make install.

I would appreciate suggestions from anyone working on
this board or anyone working on some other embedded
I have refered to FAQ.Embedded and followed similar
Also can I remove some of source code directly to
reduce the size of my port???
Also, I want my final port of the size not more than
500K-700K. I want a very simple
JVM without any advanced features, what path should I
do follow???
Thanks in advance for the effort,

(cd .libs && arm-uclibc-gcc -c -fno-builtin
rm -f .libs/kaffe-binS.c .libs/kaffe-bin.nm
.libs/kaffe-bin.nmS .libs/kaffe-bin.nmT
arm-uclibc-gcc -g -O2 -Wall -Wstrict-prototypes
-fsigned-char -o kaffe-bin -static main.o version.o
.libs/kaffe-binS.o -Wl,--export-dynamic 
../kaffevm/.libs/libkaffevm.a -ldl -lm -Wl,--rpath
cannot find -ldl
collect2: ld returned 1 exit status
rm -f .libs/kaffe-binS.o
make[2]: *** [kaffe-bin] Error 1
make[2]: Leaving directory
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory
make: *** [install-recursive] Error 1

Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://mail.messenger.yahoo.co.uk

More information about the kaffe mailing list