[kaffe] hardwiring the xscale patch

Ian Mitchell imitchel at rite-solutions.com
Thu Apr 1 07:02:02 PST 2004

Hi - I'm new at this but here goes.
My AWT app runs on an xscale using your official release - I do get
occasional crashes though.  I checked out the latest CVS and tried the
pxa switch but got hundreds of warnings and eventual failure (not
complaining - I know it is not an official release!).
So I took the CVS code in config/arm/linux and moved it to me release
area and built with the SP_OFFSET hardcoded.
When I ran (with strace) it bailed looking for jre/etc/kafferc  which
doesn't exist in my target build.
Any ideas?
Is my hardcode approach invalid or incomplete?
Am I missing something in my configure to make it need kafferc?
Do I need to tweak my cross compiler?
(I'm brushing up and catching up on my unix/linux/c skills - have been
away for 8 years)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://kaffe.org/pipermail/kaffe/attachments/20040401/d5f1a326/attachment-0007.htm 

More information about the kaffe mailing list