[kaffe] kaffe 1.1.3 on Darwin 6.8 fails

Michael Franz developer.franz at verizon.net
Sun Apr 18 20:12:02 PDT 2004


Kaffe on Darwin/OS X has never worked as long as I have been trying to 
use it.  The fact that it compiles is good, but there is something 
wrong with the resulting VM.  I have spent some time trying to get it 
working, but my time is limited.  I have not made much progress.  I 
think it is either the threading or the memory management.  I would 
very much like to see it working again!


On Sunday, April 18, 2004, at 04:54 PM, Riccardo wrote:

> Hello,
> I tried to compile kaffe 1.1.3 form the .tar.gz since that is the
> version from darwinports.
> However:
> 140 of 144 tests failed
> Please report to kaffe at kaffe.org
> and looking... compiling just doesn't work:
> java.lang.ClassFormatError: truncated class
>    at java.lang.ClassLoader.defineClass0 (ClassLoader.java)
>    at java.lang.ClassLoader.defineClass (ClassLoader.java:179)
>    at java.security.SecureClassLoader.defineClass (SecureClassLoader.
> java:33)
>    at kaffe.lang.AppClassLoader$JarSource.findClass 
> (AppClassLoader.java:
> 143)
>    at kaffe.lang.AppClassLoader.findClass (AppClassLoader.java:291)
>    at java.lang.ClassLoader.loadClass (ClassLoader.java:142)
> I hvae only one suspect, but it may be a false alarm. After
> decompressing .tar.gz I found one @LongLink file, this means that with
> one file gnu tar made a mess. It is a single case, it would be really
> bad luck. I have BSD tar and I would start advising to use BSD tar for
> kaffe distribution instead of buggy GNU crap. In any case, the guys at
> darwinports.. have BSD tar too!!!
> -Ric
> _______________________________________________
> kaffe mailing list
> kaffe at kaffe.org
> http://kaffe.org/cgi-bin/mailman/listinfo/kaffe

More information about the kaffe mailing list