[kaffe] intrp horribly broken on HP-UX

Riccardo zuse at libero.it
Wed May 12 09:24:02 PDT 2004


since some months kaffe is broken on my HP-UX box "torus" (10.20, gcc 3.
Before there were some compilation errors, now it compiles but it fails 
when je VM should start fro KJC and class library build.

I thought then of skipping this and building with jikes, but sicne JAR s 
needed and runs on the VM it fails there with the same error, this means 
the VM is deeply broken:

rm -f rt.jar
libraries/clib/zip/:../../libraries/clib/nio/ ../../kaffe/kaffe/kaffe-
bin kaffe.tools.jar.Jar -cvf rt.jar -C lib gnu java javax kaffe org
Assertion failed: !INTS_DISABLED(), file ../../../kaffe/kaffe/kaffevm/
exception.c, line 314
/bin/sh: 4305 Abort(coredump)
gmake[1]: *** [rt.jar] Error 134
gmake[1]: Leaving directory `/usr/local/kaffe-cvs/hpux-jikes/libraries/

any help/comments aprpeciated.

I think I remember that about last year kaffe once compiled and then 
worked at least up to the point of using kjc on the class library on 
that computer. BUt that is before I started archiving all the logs.


Even more strangely on a similar box, same OS version, same CPU family, 
gcc 2.95 I can' reproduce that error. But that box is slower, has almost 
no diskspace left so I cannot install jikes and thus never ended up 
having a complete rt.jar

More information about the kaffe mailing list