[kaffe] support for JDk 1.2 and higher?

Andrew John Hughes gnu_andrew at member.fsf.org
Wed Feb 16 10:55:56 PST 2005

On Wed, 2005-02-16 at 17:16 +0100, mariner ux wrote:
> Hi there, 
> I need a JVM on HP-UX 10.20 which support's JDK 1.2 and higher. I thought I
> could try it with kaffe, so I installed it.
> First the installation failed  of corse there where no Gnu MP.
> So i tried configure with the option:
> CC=gcc ./configure --prefix=/opt/kaffe --enable-pure-java-math
> Kaffe installed sucessfully. I tried to compile the source code of my
> application I worte.
> But there I have still Problems...
> Does the current version, which I installed, support JDk 1.2 and higher?

As far as library support goes (i.e. the java.*, javax.* and other
classes documented in the public API docs for the JDK), Kaffe tracks GNU
Classpath for the most part, which has support for a subset of 1.4
functionality (and increasing by the day).  I believe Kaffe also bundle
some other packages, such as javax.sound, etc.  Not sure as far as the
compiler and VM go, but I would imagine they are 1.4 compatible.

> If Yes what could be the Problems for this Errors:
> :javac HPUXldap.java
> HPUXldap.java:19: Class com.novell.ldap.LDAPAttribute not found in import.
> import com.novell.ldap.LDAPAttribute;
>        ^
> HPUXldap.java:20: Class com.novell.ldap.LDAPAttributeSet not found in
> import.
> import com.novell.ldap.LDAPAttributeSet;
>        ^
> HPUXldap.java:21: Class com.novell.ldap.LDAPConnection not found in import.
> import com.novell.ldap.LDAPConnection;
>        ^
> HPUXldap.java:22: Class com.novell.ldap.LDAPEntry not found in import.
> import com.novell.ldap.LDAPEntry;
>        ^
> HPUXldap.java:23: Class com.novell.ldap.LDAPException not found in import.
> import com.novell.ldap.LDAPException;
>        ^
> HPUXldap.java:24: Class com.novell.ldap.LDAPSearchResults not found in
> import.
> import com.novell.ldap.LDAPSearchResults;
>        ^
> HPUXldap.java:25: Class com.novell.ldap.util.Base64 not found in import.
> import com.novell.ldap.util.Base64;
>        ^

These com.novell packages are not part of the public JDK API.

> HPUXldap.java:28: Class java.util.Iterator not found in import.
> import java.util.Iterator;
>        ^

This is odd; can you please include the command you run to get this
output, as this class should be available.

> 8 errors
> Thanks, 
> Corsin

Andrew :-)

Please avoid sending me Microsoft Office (e.g. Word, PowerPoint)
See http://www.fsf.org/philosophy/no-word-attachments.html

No software patents in Europe -- http://nosoftwarepatents.com

"Value your freedom, or you will lose it, teaches history. 
`Don't bother us with politics' respond those who don't want to learn." 
-- Richard Stallman

"We've all been part of the biggest beta test the world has ever known
-- Victor Wheatman, Gartner

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://kaffe.org/pipermail/kaffe/attachments/20050216/19d57ecf/attachment-0002.pgp 

More information about the kaffe mailing list