[kaffe] Kaffe on ppc (Slackintosh Linux 2.6.x)

Mike Drozdick mikey66 at comcast.net
Thu Jun 29 08:48:39 PDT 2006

I feel your pain.

I had similar problems with a simple HelloWorld program:
- Compiled & run on CentOS 4.3 Linux
	Runs OK.
- Compiled and run on Fedora Core 5 (tried 32 and 64 bit OS)
	Segmentation Fault
- Cross-Compiled under Fedora 5 Linux for ARM target
	Segmentation fault when run on target

Note: Similar problem building native AND cross-compiling!

I spent a little time investigating with GDB.
I think the problem has to do with Threads.
The SegFault occurs in gc_small_block().
The stack trace leading to the SegFault is:
      trace in here and it's easy to see where it SegFaults

I tried rebuilding and running with internal Kaffe threads.
Same result -- SegFault.
Looking at the code, nothing obvious jumped out at me.

I tried many MANY configure permutations (e.g. --with-engine=intrp).
I also tried MANY older releases of Kaffe.
Same result.

It worked fine with my CentOS (e.g. RedHat) setup, so...
I think there is probably something very simple in the
Linux environment that will make Kaffe work.
Unfortunately, I couldn't find what it is, nor could I
get the answer anywhere I looked.

I read the claims that Kaffe has been deployed successfully
in many environments.
I was looking for something that would just work, without my having
to learn ever piece of code in the package.
I spent 12 days wrestling with Kaffe, with no useful results.

I think Kaffe lacks the critical mass of maturity and support
to make if viable for anything beyond a hobby-project.
(Look at the huge time between release dates...)

Would still like to hear the solution, if anyone finds it.
In the meantime, I'm moving on to:
  JamVM (very current, frequent releases, well documented)
  or gcj (like a rock, used in Linksys router).


-----Original Message-----
From: kaffe-bounces at kaffe.org [mailto:kaffe-bounces at kaffe.org] On Behalf Of
Sent: Thursday, June 29, 2006 6:45 AM
To: kaffe at kaffe.org
Subject: [kaffe] Kaffe on ppc (Slackintosh Linux 2.6.x)

Hi all ,

I'm new to Kaffe. I have compiled successfully Kaffe 1.1.7 on my iBook 
G4 (running Slackintosh current, Linux, but when I run 'make 
check' I get:

Method Constant Pool:
soft_fixup_trampoline(): return 0x1012de58
/bin/sh: line 4: 23653 Segmentation fault      env 
TEST_CLASSES="ConstMethods.class ConstMathMethods.class 
ParameterizedMethods.class ParameterizedMathMethods.class 
ParameterizedLogicalMethods.class ParameterizedBitwiseMethods.class 
ControlFlowMethods.class StaticMethodCall.class TypeConversion.class 
StaticFields.class PrimitiveArrays.class ObjectFields.class 
MethodOptimizations.class NativeMethodCall.class Exceptions.class 
VirtualMethod.class" `. ../../BUILD_ENVIRONMENT; 
\(.*\)/echo \1=$\1/' < ../../BUILD_ENVIRONMENT | sh` ${dir}$tst
FAIL: jitBasic
1 of 1 tests failed
Please report to kaffe at kaffe.org

When I try to run a simple HelloWorld application (compiled with jikes) 
I get:

gioco at giocoiBook:~/src$ java HelloWorldApp
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.

I also noticed that there is no Klasses.jar in /usr/local/kaffe.

I don't know how to make it work, could you help me, please?

Thanks in advance.

Chiacchiera con i tuoi amici in tempo reale! 

kaffe mailing list
kaffe at kaffe.org

More information about the kaffe mailing list